Appena qualche ora fa è stata rilasciata la nuovissima versione di EUCookieLaw3 che porta con se numerose funzionalità, tante semplificazioni e l’adeguamento tecnico dei siti al fatidico GDPR. Eppure già ho ricevuto numerosi messaggi privati nei quali mi è stato chiesto supporto…

Partendo dall’assunto che esiste anche un plugin per WordPress (in attesa di autorizzazione da parte del team di verifica di WordPress), gli utilizzatori di questo CMS potranno beneficiare delle facilitazioni già predisposte per loro.

Con questo articolo ho intenzione di chiarire una volta per tutte dove collocare lo script di EUCookieLaw3 in una pagina web per coloro che non fanno uso del CMS WordPress.

La soluzione si applica a qualsiasi tipologia di sito, che sia esso un CMS o un sito vetrina, che sia scritto in PHP, ASP, Java, Python, NodeJS o qualsiasi altro linguaggio più o meno conosciuto.

Una volta configurato il funzionamento attraverso l’editor di configurazioni, ed ottenuto il codice generato, si proceda a seguire questa mini guida.

Presupponendo che l’HTML della pagina in cui includere EUCookieLaw3 sia, nell’estremo della semplificazione il seguente:

<html>
    <head>
        <meta charset="UTF-8">
        <title>Questo è il titolo della pagina</title>
    </head>
    <body>
       ...
    </body>
</html>

EUCookieLaw3 andrà messo necessariamente subito dopo l’apertura del tag head.

<html>
    <head>
        <!-- In questo punto va messo EUCookieLaw -->
        <meta charset="UTF-8">
        <title>Questo è il titolo della pagina</title>
    </head>
    <body>
        ...
    </body>
</html>

È l’unico modo per assicurarsi che il blocco preventivo dei cookie avvenga nella pagina.

5 risposte su “EUCookieLaw 3.0 – Dove collocare lo script di configurazione?”

  1. Ho installato il plugin in WordPress caricandolo manualmente ed sembra andare bene, ottimo prodotto. Devo ancora carpirne tutte le funzionalità ma mi sembra eccellente davvero. In un altro sito, invece, restituisce questo errore: Parse error: syntax error, unexpected ‘[‘ in /web/htdocs/www.anxurtime.it/home/wp-content/plugins/EUCookieLaw3-wp-master/custom-post.php on line 38
    Non so se questo è il luogo giusto per segnalarti questo problema che non so risolvere in autonomia. Grazie !

    1. Ciao! Grazie per i complimenti e per aver iniziato ad utilizzare il plugin!!! :-)

      Come ben sai la GDPR è una direttiva europea che obbliga i siti a salvaguardare la privacy degli utenti. Essa è garantita da diversi aspetti che vanno considerati come un tutt’uno. Tanto per citarne un paio:

      • il lecito trattamento dei dati
      • garantire la sicurezza delle informazioni

      Ti ho fatto questa piccola premessa, perchè quell’errore è dato da una versione di PHP precedente alla 5.4, che a sua volta è stata rilasciata circa 5 anni fa. Dopo tale versione sono state rilasciate nuove versioni (oggi siamo alla versione 7+) tra le quali numerose patch di sicurezza ed introduzione di nuove funzionalità.

      Pertanto ti suggerisco di aggiornare la versione di PHP almeno alla 5.6 per aumentare la sicurezza del tuo sito, prima di procedere ad altri adeguamenti normativi che potrebbero essere disattesi in caso di violazione del server.

      1. Grazie Diego, immaginavo una cosa del genere. Purtroppo è il sito che gestisco per conto di alcuni amici e sono subentrato. C’è un tema anziano che non tollera nuove versioni di php perché non più aggiornato. Provo ad avanzare alla 5.6, grazie !

      2. Attivata la versione 5.6.x, il plugin si è attivato. Ora ci lavoro un attimo, grazie !!

I commenti sono chiusi

%d blogger hanno fatto clic su Mi Piace per questo: